Issues when starting Enigma docker image in SW mode


#1

I’m at the point where i am running launch_network.bash and I encountered two issues

When it is deploying the contracts to the test net I get the following issues. First coin-mixer won’t deploy.

Starting coin-mixer app...
Error: Invalid JSON RPC response: ""
    at Object.InvalidResponse (/home/node/enigma-contract/node_modules/web3-core-helpers/src/errors.js:42:16)
    at XMLHttpRequest.request.onreadystatechange (/home/node/enigma-contract/node_modules/web3-providers-http/src/index.js:75:32)
    at XMLHttpRequestEventTarget.dispatchEvent (/home/node/enigma-contract/node_modules/xhr2-cookies/dist/xml-http-request-event-target.js:34:22)
    at XMLHttpRequest._setReadyState (/home/node/enigma-contract/node_modules/xhr2-cookies/dist/xml-http-request.js:208:14)
    at XMLHttpRequest._onHttpRequestError (/home/node/enigma-contract/node_modules/xhr2-cookies/dist/xml-http-request.js:349:14)
    at ClientRequest.<anonymous> (/home/node/enigma-contract/node_modules/xhr2-cookies/dist/xml-http-request.js:252:61)
    at ClientRequest.emit (events.js:182:13)
    at Socket.socketErrorListener (_http_client.js:391:9)
    at Socket.emit (events.js:182:13)
    at emitErrorNT (internal/streams/destroy.js:82:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
    at process._tickCallback (internal/process/next_tick.js:63:19)
The second issue is the following where Surface starting.

Starting Surface...
enigma_surface_1: Waiting for enigma_core_1...
enigma_surface_1: Waiting for enigma_core_1...
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
                                                                                                   If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).
                                                                  enigma_surface_1: Waiting for enigma_core_1...
enigma_surface_1: Waiting for enigma_core_1...
enigma_surface_1: Waiting for enigma_core_1...
enigma_surface_1: Waiting for enigma_core_1...

#2

Hi @zitterbewegung, thanks for reporting this issue. The launch_network.bash script had got out of sync, as we normally do most of the development with launch_network_terminals.bash (which we find more intuitive because each container/process gets its own window).

Should be fixed now, pull the latest version from the repo enigma-docker-network and give it another try.

We have pushed some changes in the other repos, which docker may not detect in building the images, so I recommend that you run at least the following command:

docker-compose build --no-cache

to force the rebuild with the latest sources.


#3

I did docker-compose build --no-cache. After doing that I get an error about HTTP timeout related to starting surface.

Starting Surface...
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
r2q2@Jabberwocky:~/Desktop/coinsulting/enigma-docker-network$ contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
contract_1  | eth_getFilterChanges
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

#4

@zitterbewegung: I can’t reproduce your error, as the latest version of enigma-docker-network works fine for me when I run ./launch_network.bash.

Can you share more details about your setup? like host specs, docker version, your .env file

It may not be related to Enigma, but your docker setup. Maybe try this could fix it?


There are other suggestions on that thread that may resolve your issue.

Let me know if any of these resolves it for you.