Localhost:8545 refusing connections


#1

Hello,

While trying to set-up the testnet on my local computer (https://enigma.co/protocol/GettingStarted.html#setting-up-the-testnet), the launch.bash script gets stuck at “Waiting for contract to be available…”.
It seems to be due to the fact that localhost:8545 is always refusing connections.

$ curl localhost:8545
curl: (7) Failed to connect to localhost port 8545: Connection refused

localhost:8080 and localhost:8081 are also refusing connections.

Are there some additional actions to be performed to ensure that the ports are open and mapped?

List of my docker-machine:

$ docker-machine ls
NAME     ACTIVE   DRIVER       STATE     URL                         SWARM   DOCKER     ERRORS
enigma   -        virtualbox   Running   tcp://192.168.99.100:2376           v18.09.0

FYI, I am running under MacOs 10.14.1.

I found a manual workaround: use the IP of the docker-machine instead of localhost

$ docker-machine ip enigma
192.168.99.100

Then, if I replace ‘localhost’ by ‘192.168.99.100’ in:

This is not ideal as I also need to modify the base url in enigma-template-dapp

Thank you,
Michael


#2

In VirtualBox, I added the following rule for the ports 8545, 8080, 8081 and 8082:
00%20PM

This seems to be solving the issue.

Can / Should this setting be documented?

Thank you,
Michael