Problem with the millionaire problem


#7

So, I followed everything you wrote step by step. This is what I obtained:
image

Last command has a different output than yours.

Thank you for your time :slight_smile:


#8

Just a note @victor, when I encounter this problem, neither contract nor core containers launch (or they launch and immediately close… too fast for me to see)

*Also, I ran the instructions as you asked and I got the exact same output as @Fadi


#9

I tried running the following: docker-compose exec core /bin/bash

And got back this response:
root@enigma_core_1:~# core_1_46e7e72b38f7 | aesm_service[162]: SGX Service unavailable

core_1_46e7e72b38f7 | aesm_service[162]: Fail to start service.


#10

Thank you both @pmp & @Fadi for your prompt answers. I’m interested in @pmp’s hint that the other containers may not be running. Two more requests to troubleshoot this:

  • Run docker network inspect enigma_net from the same folder (not inside the container, but the host, the same folder from where you run launch.bash). This should tell us what containers are running and the network setup for these (my sample output below).
  • Bring the network down (if you had it up) with docker-compose down and the launch then docker network all in one terminal: ./launch.bash -s (without the -t, and copy/paste the output here). It’s going to be long, but I’m looking for more error messages that the other containers may be putting out that you can’t see right now because the terminals open and close too fast.

Sample output from docker network inspect enigma_net:


#11

Should just @pmp do this, or both of us?

just so I dont spam the conversation


#12

Either one of you, whoever gets to it first, because my understanding is that both of you are experiencing the same problem, so any input from either one of you would be very helpful :slight_smile:


#13

Just ran docker network inspect enigma_net. Mostly the same output as you…except my docker-compose is 1.23.0. I updated and I’m seeing three terminals now.


#14

these are the outputs:
when i run docker network inspect enigma_neti obtain:


#15

…Darn, I was too eager on my last post. The same problems persist, except now I can see all the terminals. This is the output of enigma_core:


#16

Then I run the other commands and I obtain:


#17

the rest of the output is seeable here:


#18

Thank you both. I see one of the problems here, on the network structure screenshot:

82d155b0f3731c1ebcb4c2f7b21c2d5b4650b416

They look mostly similar, but the fact that the name of the container has the 2a272b585a16 (which is presumably the container ID) attached to it, throws off the network configuration. Compare it with my screenshot above (where the name is just enigma_core_1, and that’s the most significant difference. It must be a difference in docker or docker-compose versions. Can both of you confirm what versions are you running? Run docker --version and docker-compose --version

@Fadi, the rest of the output from launching the network looks fine, thanks for including that.

@pmp, we can look later at the Rust compilation error that you include above, I cannot replicate that either, but I’ll treat that as a secondary error for the time being…


#19

docker version:


#20

I was able to get a working testnet after I installed the newest docker-compose and then removed and reinstalled the git repo. Thanks so much for your help @victor!


#21

@Fadi

as per @pmp’s fix above, can you please upgrade your docker-compose version from 1.23.1 to 1.23.2 ? For reference, see: https://docs.docker.com/compose/install/

As per docker-compose change log, they introduced a naming bug in 1.23.0 that persisted in 1.23.1 (your version from the network screenshot above) and they fixed it on 1.23.2. For reference, see:


Cannot build core container from enigma-docker-network due to method named 'trim_end_matches'
#22

I have updated the Requirements Section of the repo’s README accordingly to specify a version of docker-compose of 1.23.2 (or higher in the future).


#23

i confirm that updating Docker solved the problem. Thanks victor!


#24

Hi @victor,

after I installed Docker Compose 1.23.2 instead of 1.23.1, I cleaned my enigma directories to try again, but my machine is hanging after I try to redeploy the network with
darq-truffle migrate --reset --network development

Any ideas?


#25

Hi @myked, sorry to hear about your troubles getting started. It may be an unrelated issue. We would need more details to troubleshoot your issue. If updating docker compose did not fix it, then open a new topic on the forum and include the entire output of what you see after trying to start the network. The more info you provide, the easier it is for us to help you.


#26

You’re right, it is unrelated. It was probably some limitations of resources on the machine I was using, as it works fine on a better machine now. I’ll write back if I find the actual root cause.