Problem with the millionaire problem

#21

@Fadi

as per @pmp’s fix above, can you please upgrade your docker-compose version from 1.23.1 to 1.23.2 ? For reference, see: https://docs.docker.com/compose/install/

As per docker-compose change log, they introduced a naming bug in 1.23.0 that persisted in 1.23.1 (your version from the network screenshot above) and they fixed it on 1.23.2. For reference, see:

Cannot build core container from enigma-docker-network due to method named 'trim_end_matches'
#22

I have updated the Requirements Section of the repo’s README accordingly to specify a version of docker-compose of 1.23.2 (or higher in the future).

1 Like
#23

i confirm that updating Docker solved the problem. Thanks victor!

1 Like
#24

Hi @victor,

after I installed Docker Compose 1.23.2 instead of 1.23.1, I cleaned my enigma directories to try again, but my machine is hanging after I try to redeploy the network with
darq-truffle migrate --reset --network development

Any ideas?

#25

Hi @myked, sorry to hear about your troubles getting started. It may be an unrelated issue. We would need more details to troubleshoot your issue. If updating docker compose did not fix it, then open a new topic on the forum and include the entire output of what you see after trying to start the network. The more info you provide, the easier it is for us to help you.

#26

You’re right, it is unrelated. It was probably some limitations of resources on the machine I was using, as it works fine on a better machine now.

1 Like